using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\W_]+(?=_)";
string input = @"images/tJpwYL9baWgH56USKZwqTz7QM9g1_48x48.png
https://.../.../images/tJpwYL9baWgH56USKZwqTz7QM9g1_150x150.png";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}