$re = '/\d+?(?=;|$)/m';
$str = '23456;789012;123456;723432;212121;789012;789012;789012;789012;789012;789012';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);