import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"bitrate\":\\d+,\"width\":(\\d+),\"height\":(\\d+)";
final String string = ",\"mimeType\":\"video/mp4;+codecs=\\\"avc1.42001E,+mp4a.40.2\\\"\",\"bitrate\":353051,\"width\":640,\"height\":320,\"lastModified\":\"1543659519195688\",\"contentLength\":\"24469560\",\"quality\":\"medium\",\"fps\":24,\"qualityLabel\":\"360p\",\"projectionType\":\"RECTANGULAR\",\"averageBitrate\":35300;codecs=\\\"avc1.64001F,+mp4a.40.2\\\"\",\"bitrate\":987359,\"width\":1280,\"height\":640,\"lastModified\":\"1543660211977003\",\"quality\":\"hd720\",\"fps\":24,\"qualityLabel\":\"720p\",\"projectionType\":\"RECTANGULAR2SzYpZXq8116S_3OkA\",\"width\":336,\"height\":188},{\"url\":\"https://i.ytimg.com/vi/ddsd/maxresdefault.jpg\",\"width\":1920,\"height\":1080}]},\"videoDuration\":{\"simpleText\":\"14:03\"},\"left\":0.40175438,\"width\":0.32280701,\"top\":0.32554516,\"aspectRatio\":1.7777778,\"startMs\":\"535093\",\"endMs\":\"555093\",\"title\":{\"accessibility\":{\"accessibilityData\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}