re = /(?<=)([.,0-9]+)/m
str = 'Refined Sunflowerseed Oil 136,000 2.26 133,000 -9.33 150,000 45.20 93,667'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end