package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){\h(\S+\.xml)\h}.*?{\h[^:]+:\h(\d{4}-\d{2}-\d{2})\h}`)
var str = `| iptv: { 1 } { 8000 } { localhost.test/categories/music.xml } { golden } { 000000 } { 01 02 03 04 05 06 07 08 09 10 11 12 13 14 } { 1 } | msg: { 1 } { 0 } { Welcome expire: 2020-01-20 } { 0 } { 0 } { 00 } { 0 }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}