$re = '/^(?!.*,.*,)/m';
$str = 'I am not very good at regex and I need
I am not very good at regex, and I need
I am not very good at regex, and, I need
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);