re = /(?<=\bserver=.+?\\).+?(?=;)/m
str = 'server=testDB01\\sql14;uid=abc;pwd=def;database=ghi;language=english'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end