use strict;
my $str = '797734809
0797734809
27797734809
+27797734809';
my $regex = qr/^(?:\+?27|0)?/mp;
my $subst = '+27';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";