#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https?:\/\/)?(www\.)[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,4}\b([-a-zA-Z0-9@:%_\+.~#?&\/=]*)|(https?:\/\/)?(www\.)?(?!ww)[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,4}\b([-a-zA-Z0-9@:%_\+.~#?&\/=]*)"
Local $sString = "https://algo.com.uy" & @CRLF & _
"al.co.uk" & @CRLF & _
"al.uy" & @CRLF & _
"http://algo" & @CRLF & _
"http://algo.com" & @CRLF & _
"http://algo.ar" & @CRLF & _
"http://www.ar" & @CRLF & _
"http://" & @CRLF & _
"www.algo.com.uy.iu9" & @CRLF & _
"https://google.com" & @CRLF & _
"www.algo" & @CRLF & _
"w.algo" & @CRLF & _
"www.algo.com" & @CRLF & _
"www.cool.com.au" & @CRLF & _
"http://www.cool.com.au" & @CRLF & _
"http://www.cool.com.au/ersdfs" & @CRLF & _
"http://www.cool.com.au/ersdfs?dfd=dfgd@s=1" & @CRLF & _
"http://www.cool.com:81/index.html" & @CRLF & _
"www.go.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")