$re = '/(?P<TestName>(?<=_)\S+|[^\s_]+)$/m';
$str = '4039_ABCD
LED
2020_Adjust_Path';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);