re = /\s'(.*?)'.$/
str = 'UTC msg=\'c:\\program files\\test\\test.dll\' was created by \'NT AUTHORITY\\SYSTEM\'.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end