$re = '/(functionXY\()"[^"]*"(\);)/m';
$str = 'functionXY("Hello World");
functionXY();';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;