re = /\d+(?= dollars)/m
str = '100dollars
100 dollars
50 dollars
50 eur
500 dollars
500 pesos'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end