using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*([a-z]).*([A-Z]).*([0-9]).*([^a-zA-Z0-9- ].)*";
string input = @"dA2#";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}