using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w{1}\:{1}\/{2})(\w+\/{1})+(\w+\.{1}\w+){1}";
string input = @"c://ProgramFiles/MyDir1/MyDir2/file.ext";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}