import re
regex = re.compile(r"(?<=class=\")\s?btn(?=\s?(?:btn-)?(?:mini|small|large)?\s?\")")
test_str = ("<button class=\"btn btn-mini\" />\n"
"<button class=\"btn btn-small\" />\n"
"<button class=\"btn btn-large\"/>\n"
"<button class=\"btn\"/>\n"
"<button class=\"btn \"/>\n"
"<button class=\" btn\"/>\n"
"<button class=\"btn btn-mini btn-primary\" />\n"
"<button class=\"btn btn-small btn-success\" />\n"
"<button class=\"btn btn-large btn-info\"/>\n"
"<button class=\"btn btn-error\"/>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")