// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Host: (?:https?://)?(?<random_domain>[^:/\s]+)").unwrap();
let string = "Host: random_doamin:8080
Host: random_domain/hello
Host: random_domain
Host: http://random_doamin:8080
Host: https://random_domain/hello";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}