re = /--\s+([\s\S]*?)(?=\s+--)/
str = '-- This -- is -- one -- another -- comment --'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end