re = /(?<message>(Exception:\s)?(?i)Recaptcha\s(?<version>v\s?\d)[\w\W]+(successful|failure))/m
str = 'Exception: recaptcha v 2 validation failure'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end