const regex = /,(?![^()]*\))|(?<=\((?=[^()]{20})[^()]*),/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?![^()]*\\))|(?<=\\((?=[^()]{20})[^()]*),', 'gm')
const str = `Get index of this comma, but (not this , comma). Get other commas like, or ,or, 1,1 2 ,2. (not this ,) BUT (get index of this comma, if more than 20 characters are inside the parentheses)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}