$re = '/\'[^\']*?\'/';
$str = 'one time password for your transaction at, \'xxxx\' of inr \'1897.00\' on your xxxx bank \'debit/credit/deposit/....\' card ending \'0000\' is 0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);