using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Review: <a href=""(?<review_url>[^\""]*)\""\>(?<review>[^\>]*)";
string input = @"Change: <a href=""https://xxyyzz.com/changes/12345"">#12345</a> - Review: <a href=""https://xxyyzz.com/reviews/7890"">#7890</a>
Change: <a href=""https://xxyyzz.com/changes/1345"">#1345</a> - Review: <a href=""https://xxyyzz.com/reviews/7891"">#7891</a>
Review: <a href=""https://zzyyyxxx/reviews/205657"">205657</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}