$re = '/^.*\|cid\|(\d+)\|.*$/m';
$str = 're|cid|13324242|
wa|cid|13435464|
fs|cid|2343532|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);