import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z\\'\\-]++)([\\.\\,\\?\\!\\:\\;]+)";
final String string = "CHAPTER XXII ON THE TRAIL Tue Ludding House was on the side street of the town, about three blocks from the hotel at which our friends were stopping. When the two Rovers arrived there they found the din- ing-room had just closed and only two men and an elderly woman were in sight. “We are looking for a man who was around here—I think his name was Blackie Crowden,” said Sam. “He is a man who 'tain't, stutters very badly.” “Oh, yes, I remember that fellow,” returned one of the men who worked around the hotel, “He was here for lunch.” “Can you tell me where he is now?” “No, I cannot.” “That man who stuttered so terribly said something about going to Stockbridge,” put in the woman's. “Perhaps long-bow, he was going there.” “On foot?” “I don’t think so. Most likely he took the stage. That left about ten minutes ago.” ";
final String subst = " $1 $2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}