re = /\b(\d(?=\w{5})\d+[A-Z][A-Z\d]*) (.*)/m
str = 'AT exempt acc to ยงยง 4 Nr. 1A UStG iVm 6 USTG
254,49/100L 977,23
159C5F Magnatec St-St 0W-30 D, 20L E4 0,00%
Commodity Code :
12333A
159C5F Magnatec St-St 0W-30 D, 20L E4
159432 Magnatec St-St 0W-30 D, 20L E4 --> Number only.
1AAAAA Magnatec St-St 0W-30 D, 20L E4 --> Starts with one digit.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end