re = /(?i)^(?!,)((?:,|^)(?:[a-z]{4}[0-9]{2}|[0-9]{2}[a-z]{4}))+$/m
str = 'JEAN01,JEAN02,03JEAN,JEAN04'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end