#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(href|src|source|retinaSource|data)=(["|'][^"']*assets[^"']*\.\w{1,5})(\?[^"']*)?["|']"
Local $sString = "<a href="javascript://" class="btn btn-continue-operation disabled">" & @CRLF & _
" <span>Continuar</span>" & @CRLF & _
" </a>" & @CRLF & _
"" & @CRLF & _
"<a href='javascript://" class="btn btn-continue-operation disabled'>" & @CRLF & _
" <span>Continuar</span>" & @CRLF & _
" </a>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<ul class="footer-legal l-adjacent-list">" & @CRLF & _
" <li><a href="#external-content//genoma_transactional/cms_files/corporativo/seguridad-internet/index_transaccional.html" class="footer-legal-element clr-gray.html">{security}</a></li>" & @CRLF & _
" <li><a href='#external-content//genoma_transactional/cms_files/corporativo/sobre-ing/condiciones-servicio-tarifa_transaccional.html' class="footer-legal-element clr-gray">{link-legal-info-footer}</a></li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
" <link type="text/css" href=" assets/custom-css /infobolsa " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
".css" rel="stylesheet" media="all" charset="utf-8">" & @CRLF & _
"" & @CRLF & _
" <div class="fingerprint-views-storage-content-img txt-c">" & @CRLF & _
" {>pp-image imageId="fingerprint-activation" altText="fingerprint-activation"" & @CRLF & _
" source="assets/images/fingerprint-activation.png"" & @CRLF & _
" retinaSource="assets/images/retina/fingerprint-activation@2x.png"/}" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
"<img src="modules/cc-menu/assets/images/logo_cc.svg" alt="Components catalog">" & @CRLF & _
"" & @CRLF & _
"<img src="assets/images/twyp_cash_circle.svg?query=34"> <img src="assets/ircle.svg?hgt=76">" & @CRLF & _
"" & @CRLF & _
"{>pp-image imageId="budgets-tutorial-client-step3" altText="budget-tutorial-step3"" & @CRLF & _
" source="components/budgets-tutorial/ASSETS/images/budgets-tutorial-client-step3.png" {>pp-image imageId="budgets-tutorial-client-step3" altText="budget-tutorial-step3"" & @CRLF & _
" source="components/budgets-tutorial/ASSETS/images/budgets-tutorial-client-step3.png"" & @CRLF & _
"" & @CRLF & _
"{>pp-image source="assets/images/svg/logoING.svg"/}" & @CRLF & _
"" & @CRLF & _
" <div data-selector="logo-ing" class="padding-top-sm padding-left-sm pull-left">" & @CRLF & _
" <img id="logo" src="assets/images/svg/logoING.svg" class="img-svg svg-header-logo login-header">" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <audio data-selector="customer-connected-audio">" & @CRLF & _
" <source src="modules/remote-advisor-agent/assets/audio/incomingCall.mp3" type="audio/mp3"/>" & @CRLF & _
" </audio>" & @CRLF & _
"" & @CRLF & _
"<div class="col9">" & @CRLF & _
" <div class="declaration-image-div">{>pp-svg-image:no-products-other-bank imageId="declaration-image" source="./assets/images/life-insurance-contract/cuestionario_riesgos.svg"/}</div>" & @CRLF & _
" <p class="h5 clr-dark-gray lic-declaration-remark">{lic-risk-declaration-remark|s}</p>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div data-region-id="login-dnie-image" class="login-dnie-image"><img src="assets/images/dni-logo.png"/></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")