import Foundation
let pattern = #"\b(\w)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"name, surname, username"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)