$re = '/^(?=[\d.]{1,6}$)\d+\.?\d+$/m';
$str = '123.45
1234..
12.3
123456
123456.7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);