using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(::\s*\b(function)\b)|\b(function)\b";
string input = @"type def
integer, dimension(:), pointer :: ptr
end type def
interface set_scalar_field_from_python
module procedure set_scalar_field_from_python_sp
subroutine set_scalar_field_from_python(function, function_len, dim, &
nodes, x, y, z, t, result, stat)
use iso_c_binding, only: c_double, c_int, c_char
implicit none
integer(c_int), intent(in), value :: function_len
character(kind=c_char, len=function_len) :: function
integer(c_int), intent(in), value :: dim, nodes
real(c_double), dimension(nodes), intent(in) :: x, y, z
real(c_double), intent(in), value :: t
real(c_double), dimension(nodes), intent(out) :: result
integer(c_int), intent(out) :: stat
end subroutine set_scalar_field_from_python
! all these should be in meta.parameter.fortran
integer function fun_with_func_space( function )
integer, intent(inout) :: function
end function fun_with_func_space
subroutine sub_with_func_space( function )
character(kind=1, len=function_len), intent(inout) :: function
end subroutine sub_with_func_space
character(kind=1, len=function_len) function fun_with_sub_space( subroutine )
character(kind=1, len=function_len), intent(inout) :: subroutine
end function fun_with_sub_space
subroutine sub_with_sub_space( subroutine )
character(kind=1, len=function_len), intent(inout) :: subroutine
end subroutine sub_with_sub_space
subroutine normal( arg , simple )
character(kind=1, len=function_len), intent(inout) :: arg
integer, intent(inout) :: simple
end subroutine normal
logical(kind=4) function foo(var) result(val)
integer, intent(inout) :: var
end function foo
! keyword.other.function.fortran
function name(arg)
integer :: arg
end function name
character(len=10) function foo_char() result(val)
integer :: function
end function foo_char
end interface set_scalar_field_from_python";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}