package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`match this (?:match that)`)
var str = `match this match that`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}