$re = '/(?!\b\'\b)\'([^\']*(?:\b\'\b[^\']*)*)(?!\b\'\b)\'/m';
$str = '\'builder\'s margin\' means the percentage stated in Item 8 of Schedule 1;
Smith\'s \'rock\'n\'roll song\' ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);