$re = '`Size: (?:Age_Youth|[a-zA-Z0-9]+)(?:[ \t]*(?:or|[-/?])[ \t]*[a-zA-Z0-9]+)+`m';
$str = 'Size: 10,
Size: 12,
Size: 12M,
Size: 13-15,
Size: 14,
Size: 14.5,
Size: 15,
Size: 15.5,
Size: 16,
Size: 16.5,
Size: 17,
Size: 17.5,
Size: 18,
Size: 18.5,
Size: 18/24,
Size: 18M,
Size: 19,
Size: 19.5,
Size: 1X,
Size: 2,
Size: 2 - 18/20,
Size: 20,
Size: 20.5,
Size: 22,
Size: 22-24,
Size: 2-3-4-43621,
Size: 2-3T-4T,
Size: 24,
Size: 24",
Size: 2-4-6,
Size: 2-4-6-8-10-12-14-16-18-20,
Size: 24M,
Size: 26,
Size: 28",
Size: 28W,
Size: 29W,
Size: 2T,
Size: 2T/3T,
Size: 2T/3T-4T,
Size: 2T-3T-4T,
Size: 2T-3T-4T-43621,
Size: 2T-3T-4T-43621-7,
Size: 2T-3T-4T-5/6T,
Size: 2T-3T-4T-5T,
Size: 2T-3T-4T-5T-6T,
Size: 2T-4T-43621,
Size: 2T-4T-5/6T,
Size: 2T-4T-6T,
Size: 2X,
Size: 2XL,
Size: 3,
Size: 3 - 22/24,
Size: 30,
Size: 30-32-34-36,
Size: 30-32-34-36-38,
Size: 30-32-34-36-38-40,
Size: 30-32-34-36-38-40-42-44,
Size: 30-32-34-36-38-40-42-44-28,
Size: 30-32-34-36-38-40-42-44-46,
Size: 30-32-34-36-38-40-42-44-46-48,
Size: 30-32-34-36-38-40-42-44-48,
Size: 30-32-34-36-38-42,
Size: 30-32-34-36-40-48,
Size: 30-32-34-38,
Size: 30-32-38,
Size: 30-34-36-38-40,
Size: 30-34-38,
Size: 30W,
Size: 30W or 50W,
Size: 30W or 50W-32W-34W-36W-38W-40W-42W-44W-46W-48W,
Size: 31W,
Size: 32,
Size: 32-34-36-38,
Size: 32-34-36-38-40,
Size: 32-34-36-38-40-42-44-46-48-50,
Size: 32-34-36-38-44,
Size: 32W,
Size: 33W,
Size: 34,
Size: 34-36-38-40-42-44-46-48-50,
Size: 34-36-58,
Size: 34-56-58,
Size: 34-56-58-60-62,
Size: 34-56-58-60-62-64,
Size: 34W,
Size: 34W",
Size: 35W,
Size: 35W",
Size: 36,
Size: 36-38-40-42-44-46-48-50,
Size: 36-38-40-42-44-46-48-50-52-54,
Size: 36-38-40-42-44-46-48-50-52-54-56,
Size: 36-38-40-42-44-46-48-50-52-54-56-58,
Size: 36W,
Size: 37W,
Size: 37W",
Size: 38,
Size: 38-40-42-44-46-48-50,
Size: 38-40-42-44-46-48-50-52-54,
Size: 38-40-42-44-46-48-50-52-54-56,
Size: 38-40-42-44-46-48-50-52-54-56-58,
Size: 38W,
Size: 3T,
Size: 3T-4T-5T,
Size: 3X,
Size: 3XL,
Size: 4,
Size: 4 - 26/28,
Size: 40,
Size: 40-42,
Size: 40-42-44-46-48,
Size: 40-42-44-46-48-50-52,
Size: 40-42-44-46-48-50-52-54,
Size: 40W,
Size: 40W",
Size: 4-10-12,
Size: 41548,
Size: 42,
Size: 42-44-46-48-50,
Size: 42-44-46-48-50-52,
Size: 42-44-46-48-50-52-54-56-58,
Size: 42-44-46-48-50-52-54-56-58-60,
Size: 42-44-46-48-50-52-56-54,
Size: 42W,
Size: 43619-06-d?c,
Size: 43619-06-d?c-d?c-18,
Size: 43619-06-dc-dc-18,
Size: 43621,
Size: 43621",
Size: 43621-7,
Size: 43715,
Size: 43778,
Size: 44,
Size: 44",
Size: 4-43621-7,
Size: 44-46-48,
Size: 44W,
Size: 44W",
Size: 46,
Size: 4-6-8-10-12-14-16-18-20,
Size: 4-6-8-10-12-14-16-18-20-22,
Size: 4-6-8-10-12-14-16-18-20-22-24,
Size: 46W,
Size: 46W",
Size: 48,
Size: 48",
Size: 48-50,
Size: 48W,
Size: 48W",
Size: 4T,
Size: 4T",
Size: 4X,
Size: 4X",
Size: 5 - 30/32,
Size: 5/6T,
Size: 50,
Size: 50W,
Size: 50W",
Size: 52,
Size: 52-54,
Size: 52-56-54,
Size: 52-56-54-58-60,
Size: 52W,
Size: 54,
Size: 54",
Size: 54W,
Size: 54W",
Size: 56,
Size: 56",
Size: 56-58,
Size: 56-58-60-62,
Size: 56-58-60-62-64,
Size: 56-58-60-62-64-66,
Size: 56W",
Size: 58,
Size: 58",
Size: 58-60-62-64,
Size: 5T,
Size: 5T",
Size: 6,
Size: 60,
Size: 6-10,
Size: 62,
Size: 64,
Size: 64",
Size: 66,
Size: 6-8-10-12-14-16-18-20-22-24,
Size: 6-8-10-12-14-16-18-20-24-22,
Size: 6M,
Size: 6M-12M-18M,
Size: 6M-12M-18M-24M,
Size: 6T,
Size: 7,
Size: 8,
Size: 8",
Size: 8-10-12,
Size: 8-10-12-14",
Size: Age_Youth,
Size: Age_Youth-S/M-L/XL,
Size: d?c-18,
Size: d?c-18-18/24,
Size: dc-18-18/24,
Size: L,
Size: L/XL,
Size: M,
Size: NB,
Size: NB-6M-12M-18M,
Size: NB-6M-12M-18M-24M,
Size: NB-6M-12M-18M-24M",
Size: NB-6M-18M-24M,
Size: One Size,
Size: One Size",
Size: OS 5Pack,
Size: OS 6Pack,
Size: S,
Size: S - 5XL,
Size: S/M,
Size: S/M-L/XL,
Size: S/M-L/XL-2X/,
Size: S/M-L/XL-2XL/,
Size: S/M-L/XL-2XL/3XL,
Size: S/M-L/XL-2XL/-3XL/,
Size: S/M-L/XL-2XL/3XL-4XL/5XL,
Size: S/M-L/XL-2XL/4XL,
Size: S/M-L/XL-XL/2XL,
Size: S-L/XL,
Size: S-M-4X,
Size: S-M-L",
Size: S-M-L/XL,
Size: S-M-L-XL-2X,
Size: S-M-L-XL-2X-3X,
Size: S-M-L-XL-2XL-3XL-4X-5XL-6XL,
Size: S-M-L-XL-3X,
Size: S-M-L-XL-XXL,
Size: S-M-L-XL-XXL-3X,
Size: S-M-L-XL-XXL-3X-4X,
Size: ST,
Size: XL,
Size: XL",
Size: XS,
Size: XS/S,
Size: XS/S-M/L,
Size: XS/S-M/XL,
Size: XS/S-S/M-M/L-L/XL-XL/2XL,
Size: XS-S/M-L/XL,
Size: XS-S-M-L",
Size: XS-S-M-L-XL",
Size: XS-S-M-L-XL-2X,
Size: XS-S-M-L-XL-2X-3X,
Size: XS-S-M-L-XL-2XL",
Size: XS-S-M-L-XL-2XL-3XL-4X,
Size: XXL,
Size: XXS,
Size: XXS-3XL,
Size: XXS-S/M-L/XL-2XL/,
Size: XXS-S-L-XL,
Size: XXS-S-M-L,
Size: XXS-S-M-XL,
Size: XXS-XL-2XL-3XL,
Size: XXS-XS-M-L-XL,
Size: XXS-XS-S,
Size: XXS-XS-S-3XL,
Size: XXS-XS-S-L-XL,
Size: XXS-XS-S-M-L,
Size: XXS-XS-S-M-L-XL,
Size: XXS-XS-S-M-L-XL-2XL,
Size: XXS-XS-S-M-L-XL-2XL-3XL,
Size: XXS-XS-S-XL,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);