re = /(?<!exec )o_dwh/m
str = 'something something exec o_dwh
exec o_dwh something
something o_dwh something
o_dwh something something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end