$re = '/\bcuerpo(?!s?\W*de\sseguridad)/m';
$str = 'el cuerpo
cuerpo a cuerpo
fuerzas y cuerpos de seguridad
fuerzas y cuerpo de seguridad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);