$re = '/\/[0-9]{4}\/[0-9]{1,2}\/[0-9]+-[0-9]{1,2}/m';
$str = '/2017/04/4-29
/2018/12/6-11
/2018/11/5-22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);