$re = '/\b[A-Za-z](?: [A-Za-z]){2,}\b/m';
$str = 'somewhere in S E A T T L E.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);