import re
regex = re.compile(r"^([0-9A-F]{2}-){5}[0-9A-F]{2}$", flags=re.MULTILINE)
test_str = ("Z1-1B-63-84-45-E6\n"
"not a MAC-48 address\n"
"00-1B-63-84-45-E6")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")