package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\R+\z`)
var str = `this is a string ending with multiple newlines
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}