const regex = /(?<=[^\s=,]=\s*[^\s=,]+)\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[^\\s=,]=\\s*[^\\s=,]+)\\s+', 'gm')
const str = `x= 2-3 y=3 z= this, that`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);