import re
regex = re.compile(r"^((0?[1-9]|[12][0-9]|3[01])(Jan|JAN|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)([0-9][0-9][0-9][0-9])|(0?[1-9]|[12][0-9]|30)(Apr|APR|Jun|JUN|Sep|SEP|Nov|NOV)([0-9][0-9][0-9][0-9])|(0?[1-9]|1[0-9]|2[0-8])(Feb|FEB)([0-9][0-9][0-9][0-9])|(29)(Feb|FEB)([0-9][0-9])([02468][048]|[13579][26]))$", flags=re.MULTILINE)
test_str = ("1Jan2018 abcd\n"
"1Jan18\n"
"01Jan18\n"
"1Jan2018\n"
"01Jan2018\n"
"31Jan2018\n"
"31jan2018\n"
"31jAN2018\n"
"31JaN2018\n"
"31JAn2018\n"
"31JAN2018\n"
"28Feb2018\n"
"29Feb2018\n"
"29Feb2020\n"
"31Mar2018\n"
"30Apr2018\n"
"31Apr2018\n"
"31May2018\n"
"30Jun2018\n"
"31Jun2018\n"
"31Jul2018\n"
"31Aug2018\n"
"30Sep2018\n"
"31Sep2018\n"
"31Oct2018\n"
"30Nov2018\n"
"31Nov2018\n"
"31Dec2018")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")