re = /(?<=[;\(])([\w\s]+(et al.)?,\s+\d{4})(?=[;\)])/
str = 'What appears to us an effortless task, the opening of our eyes, engages an extensive and anatomical complex network of brain areas. The first stages of visual processing differentiate bright luminance increments from dark decrements by separate ON– and OFF–channels in the retina and dorsal lateral geniculate nucleus (dLGN) (Schiller, 1992). Most ON– and OFF–cell receptive fields (RFs) are selective for stimulus size and local contrast via antagonistic interactions between center and surround (Figure 1A) (Kuffler, 1953; Barlow et al., 1957; Allman et al., 1985). These interactions also impact the transient rebound responses when a non-preferred stimulus is removed from the RF (Singer, 1970; Jung, 1973); and they are reflected in our perceptual experience, revealing close similarities between the tuning properties of neural and perceptual RFs (Oehler, 1985; Spillmann and Werner, 1990).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end