package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)sdsd`)
var str = `sdsd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}