$re = '/^(?:(?!\b(eng|ita)\b).)*\K\beng\W+\w+\W+sub\s?ita\b/im';
$str = 'Lucifer S03e15 [XviD - Eng Mp3 - Sub Ita Eng] DLRip By Pir8 [CURA] Fede e Religioni
Lucifer S03e01-08 [XviD - Eng Mp3 - Sub Ita Eng] DLRip By Pir8 [CURA] Fede e Religioni SEASON PREMIERE
Young Sheldon S01e13 [SATRip 720p - H264 - Eng Ac3 - Sub Ita] HDTV by AVS
Young Sheldon S01e08 [Mux 1080p - H264 - Ita Eng Ac3 - Sub Ita Eng] WEBMux Morpheus
Young Sheldon S01e08 [Mux 1080p - H264 - Ita Eng Ac3 - Sub Ita Eng] WEBMux Morpheus
Young Sheldon S01e14 [SATRip 720p - H264 - Eng Ac3 - Sub Ita] HDTV by AVS
Lucifer S03e15 [XviD - Eng Mp3 - Sub Ita Eng] DLRip By Pir8 [CURA] Fede e Religioni
Lucifer S03e16 [XviD - Eng Mp3 - Sub Ita Eng] DLRip By Pir8 [CURA] Fede e Religioni
Lucifer S02e01-13 [XviD - Eng Mp3 - Sub Ita] DLRip by Pir8 [CURA] Fede e Religioni FULL
Absentia S01e01-10 [Mux 1080p - H264 - Ita Eng Ac3 - Sub Ita Eng] By Morpheus
The.X.Factor.UK.S14E01.720p.HDTV.x264-FTP[rartv]
The.X.Factor.S14E15.Judges.Houses.1.720p.AMZN.WEBRip.DDP2.0.x264-NTb[rarbg]
Face.Off.S12E07.1080p.WEB.x264-CookieMonster[rarbg]
Lucifer S02e01 [BDMux 1080p - H264 - Ita Eng Ac3 - Sub Ita Eng NUEng] By Morpheus [CURA] Fede e Religioni
Lucifer.S02E01.H264.BDMux.ITA.Ac3.ENG.Ac3.5.1.Subs.RoomCrew.mkv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);