$re = '/^X(?!X)/m';
$str = 'Xabc
Xaaa
XXabc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);