$re = '/^[a-z][a-z\' -]*/mi';
$str = 'a\' b - CD cd\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);