$re = '/^(\d*)(\D.*)$/m';
$str = '1adrian
1kg123
1kg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);