$re = '/(M:|:D:|:C:|:Q:.*?)([a-zA-Z_\\\\.0-9]+)/m';
$str = 'tcp://someurl.com:8989';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);