$re = '/[^.!?]*[.!?]/m';
$str = ' This is a sentence. Including the following phrase § 20 Abs. 4 Nr. 1 this is a sentence as well.
This is a sentence. Including the following phrase § 50 Abs. 4 this is a sentence as well.
REF:
https://forum.keyboardmaestro.com/t/regex-find-sentences-including-specific-abbreviations/11218';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);