import re
regex = re.compile(r"""
(abcd|bcde|cdef|defg|efgh|fghi|ghij|hijk|ijkl|jklm|klmn|lmno|mnop|nopq|opqr|pqrs|qrst|rstu|stuv|tuvw|uvwx|vwxy|wxyz)+
""", flags=re.IGNORECASE | re.VERBOSE)
test_str = ("aaaa\n"
"abcd\n"
"wxyz\n"
"uvwx\n"
"rupak\n"
"single characters\n"
"rupak abcd test\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")